Angelos PaaS4SaaS Blog

Wednesday, 9 February 2011

Weblogic 10.3.4 (PS3) nodemanager wont start?

Hi all, well Im back from Australia and one of the things which happened was Oracle announced the PS3 release of oracles SOA & Webcenter products have been released. Now I normally use pre-installed images but I always like to install the products at least once that way I get to see its installation caveats..

Here’s one.

Installation on Windows 7 64bit, 64bit JVM, generic weblogic Server installer.

All worked fine, EXCEPT I cant start the node manager, I get the following error

<08-Feb-2011 17:16:48> <INFO> <Loading domains file: D:\products\wls1034\WLSERV~1.3\common\NODEMA~1\nodemanager.domains>
<08-Feb-2011 17:16:48> <SEVERE> <Fatal error in node manager server>
weblogic.nodemanager.common.ConfigException: Native version is enabled but nodemanager native library could not be loaded
    at weblogic.nodemanager.server.NMServerConfig.initProcessControl(NMServerConfig.java:249)
    at weblogic.nodemanager.server.NMServerConfig.<init>(NMServerConfig.java:190)
    at weblogic.nodemanager.server.NMServer.init(NMServer.java:182)
    at weblogic.nodemanager.server.NMServer.<init>(NMServer.java:148)
    at weblogic.nodemanager.server.NMServer.main(NMServer.java:390)
    at weblogic.NodeManager.main(NodeManager.java:31)
Caused by: java.lang.UnsatisfiedLinkError: D:\products\wls1034\wlserver_10.3\server\native\win\32\nodemanager.dll: Can't load IA 32-bit .dll on a AMD 64-bit platform
    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
    at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1803)
    at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1728)
    at java.lang.Runtime.loadLibrary0(Runtime.java:823)
    at java.lang.System.loadLibrary(System.java:1028)
    at weblogic.nodemanager.util.WindowsProcessControl.<init>(WindowsProcessControl.java:17)
    at weblogic.nodemanager.util.ProcessControlFactory.getProcessControl(ProcessControlFactory.java:24)
    at weblogic.nodemanager.server.NMServerConfig.initProcessControl(NMServerConfig.java:247)
    ... 5 more

Ok it appears that the node manager has gotten confused and thinks this is a 32bit install of Weblogic Server whereas it is the 64bit install.. Might have been something I did, or didnt do, on installation (e.g. –d64 on the jvm command line), however the workaround is pretty easy.

 

1. Create a file called nodemanager.properties in %WL_HOME%\common\nodemanager

on my machine it was D:\products\wls1034\wlserver_10.3\common\nodemanager

2. Add the following line to it

NativeVersionEnabled=false

3. And start it up!, this will force it not to use .DLL files and use emulation/non native methods instead..

 

 

No comments:

Post a Comment